How to connect Claude Code, VS Code, Zapier and custom applications to your CharmIQ workspace via MCP and OAuth.
|
|
/mcp/agent | ||
/mcp/application | ||
/mcp/chat | ||
/mcp/collection | ||
/mcp/docs | ||
/mcp/generation | ||
/mcp/git | ||
/mcp/note | ||
/mcp/usage | ||
/mcp/vfs | ||
/mcp/workspace |
https://api.charmiq.ai. The base URL (https://api.charmiq.ai/mcp) exposes a list_servers tool that describes all available servers.https://api.charmiq.ai/mcp/vfs/.well-known/oauth-authorization-server/oauth/register (RFC 7591)richtext.read | |
richtext.write |
scope parameter, all scopes it's allowed to have are granted by default.sub (user), org (organization), and scope.For Developers — CharmIQ's OAuth implementation is RFC 8414 (Authorization Server Metadata) and RFC 9728 (Protected Resource Metadata) compliant. Standard MCP clients that support discovery will find CharmIQ's configuration automatically at:
| Endpoint | URL |
|----|----|
| Authorization |https://api.charmiq.ai/oauth/authorize|
| Token |https://api.charmiq.ai/oauth/token|
| Dynamic Client Registration (RFC 7591) |https://api.charmiq.ai/oauth/register|
| User Info |https://api.charmiq.ai/oauth/userinfo|
| Server Metadata |https://api.charmiq.ai/.well-known/oauth-authorization-server|
| Resource Metadata |https://api.charmiq.ai/.well-known/oauth-protected-resource|Supported grant types: authorization_code,refresh_token. Dynamic clients (public, no secret, PKCE required) are cleaned up after 90 days of inactivity.